Change Mac OS X Default PHP Version

Change your default PHP Version from Mac to Install Composer Dependencies without an Issue. Easy 5 Step to Follow

I was having trouble getting laravel to install the composer dependencies because my mac version PHP was lower than what some of the dependencies required. So I found a StackOverflow response.

brew upgrade php : ( get the latest homebrew php packages )

brew install php@7.4 : ( Install php 7.4 )

brew link php@7.4 : ( create an alias to this keg-only version; see comments output during installation )

echo 'export PATH="/usr/local/opt/php@7.4/bin:$PATH"' >> ~/.bash_profile : ( Add the alias to your path; see comments output during installation )

source ~/.bash_profile : ( Reload .bash_profile to use the new settings immediately )

Source: https://stackoverflow.com/questions/60295426/change-mac-os-x-default-php-version